My Account  |  Cart  |  

System Requirements

Suitcase Fusion 7

Macintosh

  • macOS™ v10.9.5 through 10.12 (Sierra)
  • Some features require an Internet connection
  • Safari® 7 or the latest release of Firefox® or Chrome™

Windows

  • Windows® 7 SP1, Windows 8, Windows 8.1, or Windows 10
  • Microsoft® .NET Framework version 4.5.1
  • Some features require an Internet connection
  • Internet Explorer® 10 or later, Microsoft Edge, or the latest release of Firefox or Chrome

Supported Applications

Auto-Activation Plug-in and Extensis Font Panel included for these applications:

  • Adobe Illustrator CS6, CC 2014, CC 2015, CC 2015 (Summer 2016), and CC 2017
  • Adobe InDesign CS6, CC 2014, CC 2015, and CC 2017
  • Adobe Photoshop CS6, CC 2014, CC 2015, CC 2015 (Summer 2016), and CC 2017

Auto-Activation Plug-in included for these applications:

  • Adobe InCopy CS6, CC 2014, CC 2015, and CC 2017
  • Adobe After Effects CC 2015 and CC 2017
  • QuarkXPress 10, 2015, 2016 and 2017 (Mac only)

See Full System Requirements

Suitcase Fusion for iOS

  • iPad®, iPhone®, or iPod touch® running iOS 9 or later
  • Suitcase Fusion® 7 or Suitcase TeamSync™ for macOS™ or Windows®

See Full System Requirements


Product Compatibility

Suitcase Fusion Support Guide

 

Other Resources

Suitcase Fusion 7 Uninstaller (Macintosh)